To use our apps and setups, make sure you have an active SaferVPN account

How to install SaferVPN on versions older than Mac OS X 10.8

Updated on: 2017-06-23 16:45:34 UTC

The current SaferVPN application for Mac OS X supports version 10.8 (Mountain Lion) and above.

Earlier versions (prior to 10.8) require manual configuration. 

Follow our detailed guides below for step by step instructions:  

PPTP setup for Mac OS X 

or

L2TP setup for Mac OS X

GET SAFERVPN NOW Go to top
Have more questions? Submit a request